兩套perl的問題~

兩套perl在freebsd上~有極大的機會系統會crash
用ftp裝了kern develop distribution的話,都會自動裝上per5.6的版本
而我們在裝很多軟体的時後都是須要perl5.8以上的版本,主要是須要5.8的multistring
所以ports都會自動裝上5.8的版本,這時後問題就來了
因為系統原本就有5.6的版本,然後又裝上5.8的版本,
這時後很多用到perl的程式在執行或是compile的時後很容易出現問題
so
最好的方式是在裝好os 後馬上裝cvsup-without-gui
更新ports後
把舊版的移掉然後裝上新版的
這樣對系統應該是一個比較正確的方式。

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料